Como corrigir o erro “Repository is not valid yet” no Ubuntu Linux

17 de setembro de 2020

Recentemente, instalei o servidor Ubuntu no meu Raspberry Pi. Eu o conectei ao Wi-Fi do terminal Ubuntu e fiz o que faço depois de instalar qualquer sistema Linux que é atualizar o sistema.

Recentemente, instalei o servidor Ubuntu no meu Raspberry Pi. Eu o conectei ao Wi-Fi do terminal Ubuntu e fiz o que faço depois de instalar qualquer sistema Linux que é atualizar o sistema.

Quando usei o comando sudo apt update, ocorreu um erro que era único para mim. Reclamou que o arquivo de lançamento do repositório era inválido por um determinado período.

E: Release file for http://ports.ubuntu.com/ubuntu-ports/dists/focal-security/InRelease is not valid yet (invalid for another 159d 15h 20min 52s). Updates for this repository will not be applied.

Aqui está o resultado completo:

ubuntu@ubuntu:~$ sudo apt update

Hit:1 http://ports.ubuntu.com/ubuntu-ports focal InRelease    

Get:2 http://ports.ubuntu.com/ubuntu-ports focal-updates InRelease [111 kB]                           

Get:3 http://ports.ubuntu.com/ubuntu-ports focal-backports InRelease [98.3 kB]      

Get:4 http://ports.ubuntu.com/ubuntu-ports focal-security InRelease [107 kB]                     

Reading package lists... Done

E: Release file for http://ports.ubuntu.com/ubuntu-ports/dists/focal/InRelease is not valid yet (invalid for another 21d 23h 17min 25s). Updates for this repository will not be applied.

E: Release file for http://ports.ubuntu.com/ubuntu-ports/dists/focal-updates/InRelease is not valid yet (invalid for another 159d 15h 21min 2s). Updates for this repository will not be applied.

E: Release file for http://ports.ubuntu.com/ubuntu-ports/dists/focal-backports/InRelease is not valid yet (invalid for another 159d 15h 21min 32s). Updates for this repository will not be applied.

E: Release file for http://ports.ubuntu.com/ubuntu-ports/dists/focal-security/InRelease is not valid yet (invalid for another 159d 15h 20min 52s). Updates for this repository will not be applied.

Correção do erro “release file is not valid yet” no Ubuntu e em outras distribuições Linux

Ilustração do erro no Ubuntu Linux

O motivo do erro é a diferença na hora do sistema e na hora do mundo real.

Veja, todo arquivo de repositório é assinado em alguma data e você pode ver essas informações visualizando o arquivo de lançamento:

Comandos para usar no terminal

sudo head /var/lib/apt/lists/ports.ubuntu.com_ubuntu_dists_focal_InRelease

-----BEGIN PGP SIGNED MESSAGE-----

Hash: SHA512

Origin: Ubuntu

Label: Ubuntu

Suite: focal

Version: 20.04

Codename: focal

Date: Thu, 23 Apr 2020 17:33:17 UTC

Architectures: amd64 arm64 armhf i386 ppc64el riscv64 s390x

Agora, por alguns motivos, o tempo no meu servidor Ubuntu estava no passado e é por isso que o Ubuntu reclamou que o arquivo de lançamento ainda não é válido por X tantos dias.

Se você estiver conectado à Internet, pode esperar alguns minutos para que o sistema sincronize a hora.

Se não funcionar, você pode forçar o sistema a usar a hora local como relógio de tempo real (relógio do hardware):

Comandos para usar no terminal

sudo timedatectl set-local-rtc 1

O comando timedatectl permite configurar a hora, a data e alterar o fuso horário no Linux.

Você não deve precisar reiniciar. Ele funciona imediatamente e você pode verificar atualizando o sistema Ubuntu novamente.

Se o problema for resolvido, você pode definir o relógio de tempo real para usar UTC (conforme recomendado pelo Ubuntu).

Comandos para usar no terminal

sudo timedatectl set-local-rtc 0

Isso corrigiu o problema para você?

Espero que esta dica rápida tenha ajudado você a corrigir esse erro. Se você ainda estiver enfrentando o problema, deixe-me saber na seção de comentários e tentarei ajudá-lo. description: '---' title: 'Como corrigir o erro “Repository is not valid yet” no Ubuntu Linux' header_image_file: Repository-not-valid-yet-error-ubuntu.webp revised: true taxonomy: assunto:

  • tutorial twitterenable: true twittercardoptions: summary articleenabled: true facebookenable: true original_title: 'How to Fix “Repository is not valid yet” Error in Ubuntu Linux' original_link: '/corrigindo-repository-is-not-valid-yet-ubuntu'

Recentemente, instalei o servidor Ubuntu no meu Raspberry Pi. Eu o conectei ao Wi-Fi do terminal Ubuntu e fiz o que faço depois de instalar qualquer sistema Linux que é atualizar o sistema.

Recentemente, instalei o servidor Ubuntu no meu Raspberry Pi. Eu o conectei ao Wi-Fi do terminal Ubuntu e fiz o que faço depois de instalar qualquer sistema Linux que é atualizar o sistema.

Quando usei o comando sudo apt update, ocorreu um erro que era único para mim. Reclamou que o arquivo de lançamento do repositório era inválido por um determinado período.

E: Release file for http://ports.ubuntu.com/ubuntu-ports/dists/focal-security/InRelease is not valid yet (invalid for another 159d 15h 20min 52s). Updates for this repository will not be applied.

Aqui está o resultado completo:

ubuntu@ubuntu:~$ sudo apt update

Hit:1 http://ports.ubuntu.com/ubuntu-ports focal InRelease    

Get:2 http://ports.ubuntu.com/ubuntu-ports focal-updates InRelease [111 kB]                           

Get:3 http://ports.ubuntu.com/ubuntu-ports focal-backports InRelease [98.3 kB]      

Get:4 http://ports.ubuntu.com/ubuntu-ports focal-security InRelease [107 kB]                     

Reading package lists... Done

E: Release file for http://ports.ubuntu.com/ubuntu-ports/dists/focal/InRelease is not valid yet (invalid for another 21d 23h 17min 25s). Updates for this repository will not be applied.

E: Release file for http://ports.ubuntu.com/ubuntu-ports/dists/focal-updates/InRelease is not valid yet (invalid for another 159d 15h 21min 2s). Updates for this repository will not be applied.

E: Release file for http://ports.ubuntu.com/ubuntu-ports/dists/focal-backports/InRelease is not valid yet (invalid for another 159d 15h 21min 32s). Updates for this repository will not be applied.

E: Release file for http://ports.ubuntu.com/ubuntu-ports/dists/focal-security/InRelease is not valid yet (invalid for another 159d 15h 20min 52s). Updates for this repository will not be applied.

Correção do erro “release file is not valid yet” no Ubuntu e em outras distribuições Linux

Ilustração do erro no Ubuntu Linux

O motivo do erro é a diferença na hora do sistema e na hora do mundo real.

Veja, todo arquivo de repositório é assinado em alguma data e você pode ver essas informações visualizando o arquivo de lançamento:

Comandos para usar no terminal

sudo head /var/lib/apt/lists/ports.ubuntu.com_ubuntu_dists_focal_InRelease

-----BEGIN PGP SIGNED MESSAGE-----

Hash: SHA512

Origin: Ubuntu

Label: Ubuntu

Suite: focal

Version: 20.04

Codename: focal

Date: Thu, 23 Apr 2020 17:33:17 UTC

Architectures: amd64 arm64 armhf i386 ppc64el riscv64 s390x

Agora, por alguns motivos, o tempo no meu servidor Ubuntu estava no passado e é por isso que o Ubuntu reclamou que o arquivo de lançamento ainda não é válido por X tantos dias.

Se você estiver conectado à Internet, pode esperar alguns minutos para que o sistema sincronize a hora.

Se não funcionar, você pode forçar o sistema a usar a hora local como relógio de tempo real (relógio do hardware):

Comandos para usar no terminal

sudo timedatectl set-local-rtc 1

O comando timedatectl permite configurar a hora, a data e alterar o fuso horário no Linux.

Você não deve precisar reiniciar. Ele funciona imediatamente e você pode verificar atualizando o sistema Ubuntu novamente.

Se o problema for resolvido, você pode definir o relógio de tempo real para usar UTC (conforme recomendado pelo Ubuntu).

Comandos para usar no terminal

sudo timedatectl set-local-rtc 0

Isso corrigiu o problema para você?

Espero que esta dica rápida tenha ajudado você a corrigir esse erro. Se você ainda estiver enfrentando o problema, deixe-me saber na seção de comentários e tentarei ajudá-lo.

Confira também a versão original desse post em inglês
Esse post foi originalmente publicado no site itsfoss.com. Traduzido pela rtland.team

How to Fix “Repository is not valid yet” Error in Ubuntu Linux

Propaganda
Blog Comments powered by Disqus.
Propaganda